Client Client 1.98.3.1

Bluerise

Youngster
Administrator
Joined
Aug 14, 2011
Messages
8,904
Points
63
Hello

A client update has been released with some fixes and changes after some bugs were identified following our previous update:
  • Amended the conditions for which items display within the held items pocket
  • Emoticons should no longer appear within clickable links, system messages and usernames
  • Fixed an issue where any text following a link may not appear
  • Fixed an issue where the 'Chatbubble' option was ignored on login
  • Fixed an issue where certain characters within a wiki link would be incorrectly replaced / not replaced
  • Login messages can now feature clickable links
  • Users on the ignore tab will no longer appear as online
You can download it by visiting our main website.

Thanks as always for your feedback and support.
Blue ~
 
Last edited:

Jinji

PWO's Resident Gengar
Staff member
Administrator
Joined
Aug 15, 2011
Messages
7,182
Points
83
Website
jinji.gamescodex.net
In addition to the client updates, I'm happy to announce that starting from this release, the PWO Installer contains a small update to fix a recurring issue with PWO.

Have you been annoyed by the fact that sometimes after updating PWO, certain changes - for example new settings or changes to some of the graphics - don't seem to correctly apply until you "Run as Administrator"? The reason this happens is due to a security feature that Microsoft first added to Windows Vista as part of the new User Access Control feature, and which has been kept in every version of Windows since. Effectively, if a software doesn't have Admin permissions, but tries to access files from the Program Files or Windows folders (or any subfolders thereof), Windows actually silently creates a cache of the requested files and silently uses these copies instead of the original files. (Here's a more technical explanation) Unfortunately, after PWO is updated, or you install new skins etc, these "cached" files don't get replaced. Although this situation has been well-known for a while and the "Run as Administrator" workaround has been posted many a time, we still see people complain about this very issue regularly; and I thought it was time I took time out to attempt to address this issue.

So, starting from this release, if PWO is installed to a system running a 64-bit release of Windows Vista or later, the PWO Installer will now try to locate and clear this cache before any new files are installed. Since 90% of PWO players keep the default settings when installing PWO, which include installing to "C:\Program Files (x86)\Pokemon World Online", my hope is that this small change will remove the need for the majority of players to have to run PWO as an Administrator between updates and ensure new changes apply straight away, allowing you to play without added hassle ^^

Speaking of settings, in 1.98.3, a mistake in a settings file meant some of the announced new features, such as the new emoticons, actually were disabled by default. This has been addressed as of this release, and now default to being enabled instead. Of course, you can always switch off anything you don't want in the Options panel as per usual.
 

Rygar

Youngster
Joined
Jan 2, 2014
Messages
387
Points
63
The reason this happens is due to a security feature that Windows added to Windows Vista

I'm using Windows 7. So :p


Login messages can now feature clickable links

This should prove valuable and interesting. Now log on messages for Events can feature Links directly to the Forum Post that talks about it.

-------------------------------------------------------------------------------------------------------------------------------------------

So, what I am wondering is, when will PWO learn how to update itself so I don't have to keep doing it?

"Checking for Updates" upon trying to log on.
 

shodan21

Youngster
Joined
Aug 7, 2016
Messages
221
Points
43
So, starting from this release, if PWO is installed to a system running a 64-bit release of Windows Vista or later, the PWO Installer will now try to locate and clear this cache before any new files are installed. Since 90% of PWO players keep the default settings when installing PWO, which include installing to "C:\Program Files (x86)\Pokemon World Online", my hope is that this small change will remove the need for the majority of players to have to run PWO as an Administrator between updates and ensure new changes apply straight away, allowing you to play without added hassle ^^
and if one does not install there, but instead to, say, "D:\Pokemon World Online", how does this behave?

I'm using Windows 7. So :p
which is later than Vista.
 

Jinji

PWO's Resident Gengar
Staff member
Administrator
Joined
Aug 15, 2011
Messages
7,182
Points
83
Website
jinji.gamescodex.net
and if one does not install there, but instead to, say, "D:\Pokemon World Online", how does this behave?
In your example, the issue would not present itself in the first place, as "D:\" is not a Windows protected folder :)

In actual fact, the "Run as Administrator" issue is completely alleviated if PWO is installed in a path that does not start "C:\Program Files..." or "C:\Windows...". So if you're willing to change the default PWO install path, you already can fix the problem yourself. The point of this change is to alleviate a common issue for players who are happy to stick with default settings and expect everything to "just work" ;)
 

KingTowel

New Member
Community Guide
Joined
Oct 16, 2019
Messages
30
Points
8
Something still looks off about RBs, the abilities are all screwed up. Yanmegas/Ninjask with no speed boost, pokes with Toxic/Flame Orb but wrong ability so they end up taking damage with no positives for them, and there are other examples I can't think of right now. And this didn't happen before the first client change for E4. Surely I'm not the only who noticed.
 
Top